// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"(?m)(\d{1,4}bhp|<td class="something">(.*?)<\/td>)"#).unwrap();
  let string = "1bhp
12bhp
<td class=\"something\">This is a test</td>
123bhp
1234bhp";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}