re = /(\d{1,4}bhp|<td class="something">(.*?)<\/td>)/m
str = '1bhp
12bhp
<td class="something">This is a test</td>
123bhp
1234bhp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end