package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,4}bhp|<td class="something">(.*?)<\/td>)`)
var str = `1bhp
12bhp
<td class="something">This is a test</td>
123bhp
1234bhp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}