using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,4}bhp|<td class=""something"">(.*?)<\/td>)";
string input = @"1bhp
12bhp
<td class=""something"">This is a test</td>
123bhp
1234bhp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}