$re = '/(\d{1,4}bhp|<td class="something">(.*?)<\/td>)/m';
$str = '1bhp
12bhp
<td class="something">This is a test</td>
123bhp
1234bhp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);