const regex = /(\d{1,4}bhp|<td class="something">(.*?)<\/td>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,4}bhp|<td class="something">(.*?)<\\\/td>)', 'gm')
const str = `1bhp
12bhp
<td class="something">This is a test</td>
123bhp
1234bhp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}