import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,4}bhp|<td class=\"something\">(.*?)<\\/td>)";
final String string = "1bhp\n"
+ "12bhp\n"
+ "<td class=\"something\">This is a test</td>\n"
+ "123bhp\n"
+ "1234bhp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}