# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^<table.+.(?:[n])?(?:.+)?)(<tbody>)/1<thead>/gm;t' <<< "<table class=\"table table-bordered table-responsive\" style=\"width: 100%;\">
<tbody>"