// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^<table.+.(?:[n])?(?:.+)?)(<tbody>)").unwrap();
let string = "<table class=\"table table-bordered table-responsive\" style=\"width: 100%;\">
<tbody>";
let substitution = "1<thead>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}