const regex = /(^<table.+.(?:[n])?(?:.+)?)(<tbody>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^<table.+.(?:[n])?(?:.+)?)(<tbody>)', 'gm')
const str = `<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>`;
const subst = `1<thead>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);