import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^<table.+.(?:[n])?(?:.+)?)(<tbody>)";
final String string = "<table class=\"table table-bordered table-responsive\" style=\"width: 100%;\">\n"
+ "<tbody>";
final String subst = "1<thead>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}