re = /(^<table.+.(?:[n])?(?:.+)?)(<tbody>)/m
str = '<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>'
subst = '1<thead>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result