$re = '/(^<table.+.(?:[n])?(?:.+)?)(<tbody>)/m';
$str = '<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>';
$subst = "1<thead>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;