import Foundation
let pattern = #"(^<table.+.(?:[n])?(?:.+)?)(<tbody>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1<thead>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)