# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)//gm;t' <<< "I have some-non-alphanumeric % characters remain here, I \"also, have_+ some & .here\""