$re = '/[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)/m';
$str = 'I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;