re = /[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)/m
str = 'I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result