const regex = /[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9,.\\s"](?!(?:"[^"]*"|[^"])*$)', 'gm')
const str = `I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);