#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)"
Local $sString = "I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)