using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9,.\s""](?!(?:""[^""]*""|[^""])*$)";
string substitution = @"";
string input = @"I have some-non-alphanumeric % characters remain here, I ""also, have_+ some & .here""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}