use strict;
my $str = 'I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here"';
my $regex = qr/[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";