#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(<div[^>]*>(?:\g<1>|.)*?<\/div>)"
Local $sString = "<body>" & @CRLF & _
" <article>" & @CRLF & _
" <img src="image.png">" & @CRLF & _
" <div class="menu">" & @CRLF & _
" <div>" & @CRLF & _
" <div>" & @CRLF & _
" <div></div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <p></p>" & @CRLF & _
" <div>" & @CRLF & _
" <div></div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--- some elements -->" & @CRLF & _
" </article>" & @CRLF & _
" <footer>" & @CRLF & _
" <!--- some elements -->" & @CRLF & _
" </footer>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")