import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<div[^>]*>(?:\\g<1>|.)*?<\\/div>)";
final String string = "<body>\n"
+ " <article>\n"
+ " <img src=\"image.png\">\n"
+ " <div class=\"menu\">\n"
+ " <div>\n"
+ " <div>\n"
+ " <div></div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <p></p>\n"
+ " <div>\n"
+ " <div></div>\n"
+ " </div>\n"
+ " <!--- some elements -->\n"
+ " </article>\n"
+ " <footer>\n"
+ " <!--- some elements -->\n"
+ " </footer>\n"
+ "</body>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}