import re
regex = re.compile(r"(<div[^>]*>(?:\g<1>|.)*?<\/div>)", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<body>\n"
" <article>\n"
" <img src=\"image.png\">\n"
" <div class=\"menu\">\n"
" <div>\n"
" <div>\n"
" <div></div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" <p></p>\n"
" <div>\n"
" <div></div>\n"
" </div>\n"
" <!--- some elements -->\n"
" </article>\n"
" <footer>\n"
" <!--- some elements -->\n"
" </footer>\n"
"</body>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")