#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s+)(.*?) AS ([^,]+)"
Local $sString = " column1 AS alias1," & @CRLF & _
" column2 AS alias2"
Local $sSubst = "\1'\3' => '\2'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)