re = /^(\s+)(.*?) AS ([^,]+)/m
str = ' column1 AS alias1,
column2 AS alias2'
subst = '\\1\'\\3\' => \'\\2\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result