using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s+)(.*?) AS ([^,]+)";
string substitution = @"\1'\3' => '\2'";
string input = @" column1 AS alias1,
column2 AS alias2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}