const regex = /^(\s+)(.*?) AS ([^,]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s+)(.*?) AS ([^,]+)', 'gm')
const str = ` column1 AS alias1,
column2 AS alias2`;
const subst = `\1'\3' => '\2'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);