use strict;
my $str = ' column1 AS alias1,
column2 AS alias2';
my $regex = qr/^(\s+)(.*?) AS ([^,]+)/mp;
my $subst = '\\1\'\\3\' => \'\\2\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";