#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(?:[^{}]|(?R))*\}"
Local $sString = "2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well" & @CRLF & _
"ok: [goingwell] => {" & @CRLF & _
" "asd12asd_1231": {" & @CRLF & _
" "aa":"bb"," & @CRLF & _
" "aaa":"bbb"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue..." & @CRLF & _
"2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")