re = /\{(?:[^{}]|(?R))*\}/
str = '2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well
ok: [goingwell] => {
"asd12asd_1231": {
"aa":"bb",
"aaa":"bbb"
}
}
2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...
2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end