use strict;
my $str = '2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well
ok: [goingwell] => {
"asd12asd_1231": {
"aa":"bb",
"aaa":"bbb"
}
}
2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...
2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...';
my $regex = qr/\{(?:[^{}]|(?R))*\}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}