import re
regex = re.compile(r"\{(?:[^{}]|(?R))*\}")
test_str = ("2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well\n"
"ok: [goingwell] => {\n"
" \"asd12asd_1231\": {\n"
" \"aa\":\"bb\",\n"
" \"aaa\":\"bbb\"\n"
" }\n"
"}\n"
"2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...\n"
"2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")