import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[^\\{\\}]|(?R))*\\}";
final String string = "2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well\n"
+ "ok: [goingwell] => {\n"
+ " \"asd12asd_1231\": {\n"
+ " \"aa\":\"bb\",\n"
+ " \"aaa\":\"bbb\"\n"
+ " }\n"
+ "}\n"
+ "2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...\n"
+ "2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}