using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:[^{}]|(?R))*\}";
string input = @"2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well
ok: [goingwell] => {
""asd12asd_1231"": {
""aa"":""bb"",
""aaa"":""bbb""
}
}
2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...
2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}