import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<protocol>((https?)|(sftp)|(ftps?):))?(\\/\\/)?(?<domain>([a-zA-Z0-9\\._-]+))+(?<path>([\\/\\w.]+))*(\\?{0,1})(?<parameters>([&|&]*([\\w\\.,-]*=*[\\w\\.,-]*)))*$";
final String string = "ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}