re = /^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$/
str = 'ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end