use strict;
my $str = 'ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5';
my $regex = qr/^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}