import Foundation
let pattern = #"^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}