$re = '/^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$/';
$str = 'ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);