const regex = /^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<protocol>((https?)|(sftp)|(ftps?):))?(\\\/\\\/)?(?<domain>([a-zA-Z0-9\\._-]+))+(?<path>([\\\/\\w.]+))*(\\?{0,1})(?<parameters>([&|&]*([\\w\\.,-]*=*[\\w\\.,-]*)))*$', '')
const str = `ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}