using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s+href=""http:(?!\/\/(?:www\.)?example\.com)[^""]*"")>";
string substitution = @"\1 target=""_blank"">";
string input = @"<a href=""/somepage.htm"">1</a>
<a href=""http://www.somesiteexternal.com/"">2</a>
<a href=""http://www.example.com/somepage.htm"">3</a>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}