import Foundation
let pattern = #"(<a\s+href="http:(?!\/\/(?:www\.)?example\.com)[^"]*")>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="/somepage.htm">1</a>
<a href="http://www.somesiteexternal.com/">2</a>
<a href="http://www.example.com/somepage.htm">3</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 target="_blank">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)