$re = '~(<a\s+href="http:(?!\/\/(?:www\.)?example\.com)[^"]*")>~is';
$str = '<a href="/somepage.htm">1</a>
<a href="http://www.somesiteexternal.com/">2</a>
<a href="http://www.example.com/somepage.htm">3</a>
';
$subst = "\1 target=\"_blank\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;