re = /(<a\s+href="http:(?!\/\/(?:www\.)?example\.com)[^"]*")>/i
str = '<a href="/somepage.htm">1</a>
<a href="http://www.somesiteexternal.com/">2</a>
<a href="http://www.example.com/somepage.htm">3</a>
'
subst = '\\1 target="_blank">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result