import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a\\s+href=\"http:(?!\\/\\/(?:www\\.)?example\\.com)[^\"]*\")>";
final String string = "<a href=\"/somepage.htm\">1</a>\n"
+ "<a href=\"http://www.somesiteexternal.com/\">2</a>\n"
+ "<a href=\"http://www.example.com/somepage.htm\">3</a>\n";
final String subst = "\\1 target=\"_blank\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}