#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:azienda|societa)'\s+(.*?)\s+ha"
Local $sString = "Vista la domanda presentata in data 26 febbraio 2021 con la quale" & @CRLF & _
"la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la" & @CRLF & _
"riclassificazione dalla classe C(nn) alla classe H del medicinale" & @CRLF & _
"«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C." & @CRLF & _
"n. 049207032, 049207044, 049207018 e 049207020;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")