// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:azienda|societa)'\s+(.*?)\s+ha").unwrap();
let string = "Vista la domanda presentata in data 26 febbraio 2021 con la quale
la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la
riclassificazione dalla classe C(nn) alla classe H del medicinale
«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.
n. 049207032, 049207044, 049207018 e 049207020;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}