import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:azienda|societa)'\\s+(.*?)\\s+ha";
final String string = "Vista la domanda presentata in data 26 febbraio 2021 con la quale\n"
+ "la societa' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la\n"
+ "riclassificazione dalla classe C(nn) alla classe H del medicinale\n"
+ "«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.\n"
+ "n. 049207032, 049207044, 049207018 e 049207020;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}