re = /(?:azienda|societa)'\s+(.*?)\s+ha/m
str = 'Vista la domanda presentata in data 26 febbraio 2021 con la quale
la societa\' Orpha-Devel Handels Und Vertriebs GMBH ha chiesto la
riclassificazione dalla classe C(nn) alla classe H del medicinale
«Tresuvi» (treprostinil) relativamente alle confezioni aventi A.I.C.
n. 049207032, 049207044, 049207018 e 049207020;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end